Wróć do informacji o e-podręczniku Udostępnij materiał Wydrukuj

Wyznaczenie daty następnego dnia roboczego

Załóżmy, że mamy arkusz z terminami wysyłek. Chcemy, aby obok kolumny z terminem wysłania pojawiła się maksymalna data dostarczenia przesyłki, która jest równa dacie następnego dnia roboczego.

Aby rozwiązać to zadanie, możesz posłużyć się formułą opartą na funkcji JEŻELI. W tym celu:

  1. W komórce C2 wpisz formułę:

=JEŻELI(DZIEŃ.TYG(B2;2)=5;B2+3;JEŻELI(DZIEŃ.TYG(B2;2)=6;B2+2;B2+1))

Formuła sprawdza, jaki jest dzień tygodnia w komórce B2. Jeśli funkcja DZIEŃ.TYG zwróci wartość 5, oznacza to, że w komórce B2 jest data oznaczająca piątek – wtedy formuła dodaje 3 dni do daty znajdującej się w komórce B2. Jeśli funkcja DZIEŃ.TYG zwróci wartość 6, to oznacza, że w komórce B2 jest sobota – wtedy formuła dodaje dwa dni do daty znajdującej się w komórce B2. W pozostałych przypadkach formuła dodaje tylko jeden dzień do daty znajdującej się w komórce B2.

  1. Jeśli w komórce pojawi się data, to przejdź do kroku 6. Jeżeli pojawi się liczba, to zaznacz komórkę C2 i otwórz okno formatowania komórek.

Pamiętajmy, że data to też liczba – tylko inaczej sformatowana. Każda data to liczba dni, które upłynęły od 31 grudnia 1899 r.

  1. Przejdź do zakładki Liczby.

  2. Na liście Kategoria wybierz Data, a na liście Typ wybierz odpowiedni format daty.

  3. Naciśnij przycisk OK, aby zatwierdzić zmianę formatu liczbowego komórki.

  4. Zaznacz komórkę D2 i wybierz polecenie Kopiuj, aby skopiować komórkę.

  5. Zaznacz pozostałe komórki w kolumnie i wybierz polecenie Wklej, aby wkleić formuły do komórek.

ROyEs3m01KY2V1
Film nawiązujący do treści materiału

Na filmie możesz zobaczyć, jak wygląda efekt końcowy.

RLBFc91Q9oEoX

Pobierz załącznik

Plik XLSX o rozmiarze 13.14 KB w języku polskim
Polecenie 1

Planujesz wysłać prezent urodzinowy do przyjaciółki w Anglii. Chcesz, aby paczka dotarła do niej przed dniem urodzin, które są 19 maja. Kiedy najpóźniej należy wysłać paczkę, aby dotarła na czas, biorąc pod uwagę, że przesyłka wysłana z Polski do Anglii dociera w 2 dni robocze?

Polecenie 2

Zmodyfikuj arkusz z poprzedniego zadania i oblicz, ile taka paczka byłaby w trasie, jeżeli przyjmiemy, że tydzień roboczy trwa od piątku do niedzieli.