Wróć do informacji o e-podręczniku Udostępnij materiał Wydrukuj

Wyznaczanie lat przestępnych

W arkuszu mamy kolumnę zawierającą same lata. Chcemy szybko sprawdzić, który rok był przestępny, a który nie. Jakiej funkcji możemy użyć, aby to zrobić? W tym przypadku nie można skorzystać z domyślnie dostępnych funkcji Excela. Dlatego musimy sami zbudować odpowiednią formułę. Jednak najpierw przypomnijmy krótką charakterystykę roku przestępnego: latami przestępnymi są wszystkie lata podzielne bez reszty przez 400 oraz wszystkie pozostałe podzielne bez reszty przez 4.

Aby sprawdzić, czy rok wpisany w komórce A1 jest przestępny, wykonajmy następujące czynności:

  1. Do komórki B1 wstaw następującą formułę:

=JEŻELI(MOD(A1;400)=0;"";JEŻELI(MOD(A1;100)=0;"nie";JEŻELI(MOD(A1;4)=0;"";"nie")))&"przestępny"
  1. Skopiuj ją do komórek poniżej.

Odpowiedź uzyskamy bardzo szybko. Przedstawiona formuła ma tę zaletę, że można ją stosować dla każdej daty, bez konieczności uwzględnienia ograniczenia Excela od roku 1900.

RRj3zw29eoI3N1
Film nawiązujący do treści materiału
R1HvKGlxkRqL1

Pobierz załącznik

Plik XLSX o rozmiarze 12.89 KB w języku polskim
Polecenie 1

Przy pomocy arkusza kalkulacyjnego sprawdź, kiedy będą wypadały kolejne Mistrzostwa Europy w Piłce Nożnej, jeżeli zwykle wypadają one w lata przestępne.

Polecenie 2

Jeżeli twój kuzyn urodziłby się w roku przestępnym, dnia 29 lutego, to ile razy do tej pory, tak naprawdę obchodziłby swoje urodziny?