Wróć do informacji o e-podręczniku Udostępnij materiał Wydrukuj

Wyszukiwanie wartości

Wyszukiwanie wartości w Excelu za pomocą klawiszy [Ctrl]+[F] nie przyda się, jeżeli chcemy znaleźć jakąś wartość i umieścić ją od razu w innej komórce. W takiej sytuacji musimy skorzystać z funkcji specjalnych. Załóżmy, że mamy tabelkę taką jaką widzisz na filmie. Przedstawia ona przykładowe zestawienie towarów, cen i sprzedawców. Na jej dole będziemy pokazywać testowane formuły oraz zwracane przez nie wyniki.

Wyszukiwanie konkretnego towaru na liście

Załóżmy, że chcemy znaleźć na liście towarów figurkę żaby i w komórce wpisać nazwę jej sprzedawcy. W tym przypadku skorzystajmy z formuły:

=WYSZUKAJ.PIONOWO("Figurka żaby"; B2:D6; 3; FAŁSZ)

Formuła WYSZUKAJ.PIONOWO działa w ten sposób, że w zadanym zakresie komórek wyszukuje określoną wartość i po jej znalezieniu zwraca zawartość komórki w tym samym wierszu, ale w innej, podanej kolumnie. Składnia tej formuły jest następująca: WYSZUKAJ.PIONOWO(szukana_wartość;tablica;nr_kolumny;kolumna).

Teraz już wiemy, że użycie funkcji

=WYSZUKAJ.PIONOWO("Figurka żaby"; B2:D6; 3; FAŁSZ)

spowodowało:

  1. Szukanie przez arkusz kalkulacyjny w kolumnie B (komórki B2, B3, B4 itd.) komórki o zawartości brzmiącej dokładnie tak: „Figurka żaby”.

  2. Znalezienie komórki o takiej zawartości (B4).

  3. Znalezienie komórki w tym samym wierszu, ale w trzeciej z kolei kolumnie (kolumna B jest kolumną pierwszą), czyli komórki D4.

  4. Wypisanie zawartości komórki D4.

Korzystając z tej funkcji pamiętajmy, aby przeszukiwane wartości z pierwszej kolumny nie zawierały spacji na początku ani na końcu ciągu, cudzysłowów tak prostych ( lub ), jak i drukarskich ( lub ) ani znaków niedrukowanych. Może to spowodować nieprawidłowe działanie funkcji. Wyszukując przy użyciu dopasowania dokładnego, możemy też w szukana_wartość zastosować tzw. znaki wieloznaczne. Chodzi tu o znak pytajnika (?) zastępujący jeden dowolny znak oraz o gwiazdkę (*) zastępującą dowolną liczbę znaków. Na przykład:

  • Figurka* znajdzie Figurka osła, Figurka bociana;

  • Figurka ?aby znajdzie Figurka żaby, Figurka baby.

Wyszukiwanie wartości przy użyciu dopasowania przybliżonego

Załóżmy, że mamy do wydania 50 zł i w naszej tabeli chcemy znaleźć sprzedawcę, który oferuje produkt za taką samą cenę lub mniejszą. W takiej sytuacji użyjemy formuły: =WYSZUKAJ.PIONOWO(50;C2:D6;2;PRAWDA).

Parametr PRAWDA powoduje, że Excel w braku dokładnego dopasowania znajdzie komórkę, która ma kolejną największą wartość mniejszą od 50 (czyli 40).

Z wyszukiwania przy użyciu dopasowania przybliżonego można korzystać, tylko gdy przeszukiwane wartości są posortowane w kolejności rosnącej.

R2Mm2TXkCRV0l1
Film nawiązujący do treści materiału

Pobierz przykładowe dane:

R1aOkqXn2tw2c

Pobierz załącznik

Plik XLSX o rozmiarze 9.29 KB w języku polskim
Ćwiczenie 1

Ciocia poprosiła cię o pomoc w sklepie internetowym. Stwórz arkusz, który będzie zawierał wszystkie produkty, które są w magazynie oraz ich ceny. Drugi arkusz zawiera listę zamówień złożonych w ostatnim czasie. Tabela zawiera takie kolumny jak: nazwa produktu, cena produktu, nr klienta, wartość, która jest iloczynem ceny oraz liczby sztuk, wartość produktu, cena produktu, która jest pobierana z drugiego arkusza, liczba sztuk.

Ćwiczenie 2

Oblicz średnią kwotę transakcji. Znajdź produkt, za którego zakup klient zapłacił kwotę najbliższą średniej.